package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}`)
var str = `127.0.0.1
a.b.c.d
127 0 0 1
251.147.187.212
174.238.178.106
186 40 44 191
127..0.0.1
127 0 0 1
127. 0 0 1
127. .. 0 .. . 0. . .1
127001
183.... 183.... 183.... 183d
127.0.0.1
127.
0.
0.
1
1111.1.1.1
1
127.0.0.1
1
1
1
1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}