import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b\\d{1,3}[.[^\\S\\r\\n]]+\\d{1,3}[.[^\\S\\r\\n]]+\\d{1,3}[.[^\\S\\r\\n]]+\\d{1,3}";
final String string = "127.0.0.1\n"
+ "a.b.c.d\n"
+ "127 0 0 1\n"
+ "251.147.187.212\n"
+ "174.238.178.106\n"
+ "186 40 44 191\n"
+ "127..0.0.1\n"
+ "127 0 0 1\n"
+ "127. 0 0 1\n"
+ "127. .. 0 .. . 0. . .1\n"
+ "127001\n"
+ "183.... 183.... 183.... 183d\n"
+ "127.0.0.1\n"
+ "127.\n"
+ "0.\n"
+ "0.\n"
+ "1\n"
+ "1111.1.1.1\n"
+ "1\n"
+ "127.0.0.1 \n"
+ "1\n"
+ "1\n"
+ "1\n"
+ "1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}