use strict;
my $str = '127.0.0.1
a.b.c.d
127 0 0 1
251.147.187.212
174.238.178.106
186 40 44 191
127..0.0.1
127 0 0 1
127. 0 0 1
127. .. 0 .. . 0. . .1
127001
183.... 183.... 183.... 183d
127.0.0.1
127.
0.
0.
1
1111.1.1.1
1
127.0.0.1
1
1
1
1';
my $regex = qr/\b\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}[.[^\S\r\n]]+\d{1,3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}