#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)hreflang\s*=\s*['"]?de-de[^>]+href\s*=\s*['"]?([^'"]*)['"]?|href\s*=\s*['"]?([^"']*)['"]?[^>]+hreflang\s*=\s*['"]?de-de['"]?"
Local $sString = "<link rel="alternate" hreflang="de-de" href="https://zrce.eu/" />" & @CRLF & _
"<link rel="alternate" hreflang="en-us" href="https://zrce.eu/en/" />" & @CRLF & _
"<link rel="alternate" hreflang="it-it" href="https://zrce.eu/it/" />" & @CRLF & _
"<link hreflang="de-de" rel="alternate" href="https://zrce.eu/" />" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")