using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(?:\/\/|\*).*)((?:export|import)[\s\w*,{}]*(?=\sfrom)|export\b\s*(?:[*{]|\w\s?.+)|await import|import\.meta\.(?:env(?:\.\w+)?|resolve|url))";
string input = @"import * as foo from 'foo'
import { foo } from 'foo'
import {
foo,
bar
} from 'foo'
import.meta.env
import.meta.env.foo
import.meta.url
import.meta.resolve
export * from './foo'
export { default } from './foo'
export {
foo,
bar
} from 'foo'
export async function
// export async function
/**
*
* @example
* export default foo = 123
*
*/
await import
export default foo
export default function foo
export default () => {
}
export class
export type";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}