re = /(?<!(?:\/\/|\*).*)((?:export|import)[\s\w*,{}]*(?=\sfrom)|export\b\s*(?:[*{]|\w\s?.+)|await import|import\.meta\.(?:env(?:\.\w+)?|resolve|url))/m
str = 'import * as foo from \'foo\'
import { foo } from \'foo\'
import {
foo,
bar
} from \'foo\'
import.meta.env
import.meta.env.foo
import.meta.url
import.meta.resolve
export * from \'./foo\'
export { default } from \'./foo\'
export {
foo,
bar
} from \'foo\'
export async function
// export async function
/**
*
* @example
* export default foo = 123
*
*/
await import
export default foo
export default function foo
export default () => {
}
export class
export type'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end