import Foundation
let pattern = #"(?<!(?:\/\/|\*).*)((?:export|import)[\s\w*,{}]*(?=\sfrom)|export\b\s*(?:[*{]|\w\s?.+)|await import|import\.meta\.(?:env(?:\.\w+)?|resolve|url))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
import * as foo from 'foo'
import { foo } from 'foo'
import {
foo,
bar
} from 'foo'
import.meta.env
import.meta.env.foo
import.meta.url
import.meta.resolve
export * from './foo'
export { default } from './foo'
export {
foo,
bar
} from 'foo'
export async function
// export async function
/**
*
* @example
* export default foo = 123
*
*/
await import
export default foo
export default function foo
export default () => {
}
export class
export type
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)