// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r"Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)").unwrap();
  let string = "Audit Success,16/03/2017 12:01:08,Microsoft-Windows-Eventlog,1107,Event processing,The event logging service encountered an error while processing an incoming event from publisher  and trying to process the metadata for it.";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}