Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
stone *variant=([^\s]*)
/
gi
Test String
New
setblock ~ ~ ~ minecraft:stone variant=granite aadsdasdsad execute @e[type=ArmorStand] ~ ~ ~ setblock ~ ~ ~ minecraft:stone variant=granite
Substitution
Processing...
stone 1