Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<=\[)([一-龠])?([ぁ-ん])?([一-龠])?([ぁ-ん]{1,4})?[一-龠]?([ァ-ヴー]+|([ぁ-ん]{1,2}))?(う|く|す|つ|ぬ|ふ|む|る|ぐ|ぶ)(\-(他|自)動詞)?(?=\]\|は)
/
gm
Input 1
1
New
目指す[目指す]|は[は] 国家[国家]|資格[資格]