// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\bstyle(?:="[^"]*")?"#).unwrap();
let string = "style=\"font-family:"Open Sans", Arial, sans-serif;background-color:rgb(255, 255, 255);display:inline !important;\"
style=\"\"
style=\"something\"
style
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}