$re = '/(.){1}(?<!;|\n|\r|\t)(")(?!;|\n|\r|\t)(.){1}/s';
$str = '"ModifTextePub";"ModifObservation";"Resume"Vitrine";"Observations"Criteres"";"InternetOK";"NumPhoto";"AmianteLe";"SNavantLe";"ActePrec";"ProprietairesPrec";"Situation";"FraisNotaires"';
$subst = "$1$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;