# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.){1}(?<!;|\n|\r|\t)(\")(?!;|\n|\r|\t)(.){1}"
test_str = "\"ModifTextePub\";\"ModifObservation\";\"Resume\"Vitrine\";\"Observations\"Criteres\"\";\"InternetOK\";\"NumPhoto\";\"AmianteLe\";\"SNavantLe\";\"ActePrec\";\"ProprietairesPrec\";\"Situation\";\"FraisNotaires\""
subst = "$1$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.