re = /<.*(bur).*?>/m
str = 'bench testedstarter, starter just makes noise, and <hasburnt> <electrical> smell.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end