using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<curlyStuff>\{[^}]+\})?(?P<nodeName>\w+)\b";
string input = @"nodeName1
{http://datex2.eu/schema/2/2_0}nodeName2
nodeName3";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}