$re = '/^((\d{8})|(\d{10})|(\d{11})|(\d{6}-\d{5}))?$/m';
$str = '52341782';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);