$re = '/\(([H|G]{1}[0-9]+)\)/m';
$str = '<span style=\\"color: red; font-weight: bold;\\"> (G4) The same as <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H9&t=KJV\\" title=\\"English: lost thing, that which was lost\\"><span class=\\"Hb\\">אֲבֵדָה</span> (H9)</a>, incorrectly written for <a class=\\"nowrap\\" href=\\"lexicon.cfm?strongs=H11&t=KJV\\" title=\\"English: destruction\\"><span class=\\"Hb\\">אֲבַדּוֹן</span> (H11)</a> ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);