$re = '/(?<=^|[a-zA-Z ])(0[0-9]|1[12]|[1-9])(?:\/|\\\\)([\d]{4})(?=[a-zA-Z ]|$)/m';
$str = 'The range of dates go from 21/02/2020 to 21/03/2020 as specified above
The range of dates go from 21/2/2020 to 21/3/2020 as specified above
The range of dates go from 21/2/2020 to 21/23/2020 as specified above
The range of dates go from 2/2020 to 23/2020 as specified above
The range of dates go from 12/2020 to 23/2020 as specified above
The range of dates go from 05/2020 to 23/2020 as specified above
05/2020 test
test 05/2020';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);