using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=\b.{48}\b)[A-Z0]*0[A-Z0]*";
string input = @"AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAAAGDKJAGDJKASGDKJASGDKYQGWUDVASA
AUSGKAJDGAYGDKJAA0GDKJAGDJKASGDKJASGDKYQGWUDVASAB
AUSGKAJDGAYGDKJAA0KJAGDJKASGDKJASGDKYQGWUDVASA
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGDKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJAS0GDKJAGDJKASGDKJASGAAAAAAADKYQGWUDVAS0 jumped over the fence
quick brown fox AUSGKAJDGAYGDKJASBGDKJAGDJKASGDKJASGDKYQGWUDVASA jumped over the fence";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}