$re = '/[0-9A-F][0-9A-F][0-9A-F]/m';
$str = '1H8 4E2 8FF 0P1 T8B 776 42B G12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);