const regex = /(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:Chain ([\\d]).*{)((((?:\\w+\\s*)+):([\\d.-]+)C )+)', 'gm')
const str = `Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}