re = /(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)/m
str = 'Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end