// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:Chain ([\d]).*{)((((?:\w+\s*)+):([\d.-]+)C )+)").unwrap();
let string = "Chain 1 --> {PCB Temp A:22C B:22C C:24C Catalina Temp:12C }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}