const regex = /^(?:[0-9]|[0-8][0-9]|90)(?:\.\d+)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-9]|[0-8][0-9]|90)(?:\\.\\d+)?$', 'gm')
const str = `91
90
90.45
90.9999
0
0.23
9
80
71
7
2
0.12
3.4
33
68
54
901
92
91.1
90.99
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}