re = /^([\x{0030}-\x{0039}]+|[\x{0660}-\x{0669}]+)$/m
str = '#YES
0
1
2
3
4
5
6
7
8
9
٠
١
١٠
432
34
#Not sure, mixing two sets
1٠2
#NO
1a
s
s324'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end