#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[1]{1}[7-9]{1}\d{6}$|^[2]{1}[0-2]{1}\d{6}$"
Local $sString = "17254354" & @CRLF & _
"23464515" & @CRLF & _
"16434553" & @CRLF & _
"13462164" & @CRLF & _
"12564562" & @CRLF & _
"22346612" & @CRLF & _
"18613232" & @CRLF & _
"19561322" & @CRLF & _
"20351615" & @CRLF & _
"21561321" & @CRLF & _
"11326562" & @CRLF & _
"10320132"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")