const regex = /^[1]{1}[7-9]{1}\d{6}$|^[2]{1}[0-2]{1}\d{6}$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1]{1}[7-9]{1}\\d{6}$|^[2]{1}[0-2]{1}\\d{6}$', 'gmi')
const str = `17254354
23464515
16434553
13462164
12564562
22346612
18613232
19561322
20351615
21561321
11326562
10320132`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}