$re = '/(\[expr\s+)((?:(\[(?:[^][]++|(?3))*])|[^][{}])*)(])/';
$str = 'set a [expr $sumy+1]
set b [[expr $sumy+1] [expr $sumy+2] [expr $sumy+3]]
set c [expr $sumy+[lindex $coords 1]]
set d [expr [lindex [$ret] 2] + $Alpha]
set e [string range $SECNAME 0 [expr [string first - $SECNAME] -1] ]
set a [expr {$sumy+1}]';
$subst = "$1{$2}$4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;