$re = '~(?:[^@]+@[^,]+\,){3}~m';
$str = 'u32iygsfotd4x4@zq0q2qmhkr.com, oni26h0b9g@rciq1js1qq.com, x8_2q5yzig4hn@w8zktw.com,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);