re = /^[\w\-.]+@(stud.)?noroff.no$/m
str = 'baduser@not-noroff.no
gooduser@noroff.no
goodstudent@stud.noroff.no'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end