import re
regex = re.compile(r"^\s*(?<name>[^|]+?)\s*\|\s*(?<value>[^|]+?)\s*\|\s*(?<unit>[^|]+?)\s*\|\s*(?<status>[^|]+?)\s*\|\s*(?<type>[^|]+?)\s*\|\s*(?<state>[^|]+?)\s*\|\s*(?<lower_nonrec>[^|]+?)\s*\|\s*(?<lower_crit>[^|]+?)\s*\|\s*(?<lower_noncrit>[^|]+?)\s*\|\s*(?<upper_crit>[^|]+?)\s*$", flags=re.MULTILINE)
test_str = ("CPU1 Temp | 0x0 | discrete | 0x0000| na | na | na | na | na | na \n"
"CPU2 Temp | 0x0 | discrete | 0x0000| na | na | na | na | na | na \n"
"System Temp | 35,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 75,000 | 77,000 | 79,000 \n"
"CPU1 Vcore | 1,200 | Volts | ok | 0,656 | 0,664 | 0,672 | 1,352 | 1,360 | 1,368 \n"
"CPU2 Vcore | 0,936 | Volts | ok | 0,656 | 0,664 | 0,672 | 1,352 | 1,360 | 1,368 \n"
"CPU1 DIMM | 1,520 | Volts | ok | 1,184 | 1,192 | 1,200 | 1,648 | 1,656 | 1,664 \n"
"CPU2 DIMM | 1,520 | Volts | ok | 1,184 | 1,192 | 1,200 | 1,648 | 1,656 | 1,664 \n"
"+1.5V | 1,504 | Volts | ok | 1,320 | 1,328 | 1,336 | 1,656 | 1,664 | 1,672 \n"
"+3.3V | 3,240 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696 \n"
"+3.3VSB | 3,216 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696 \n"
"+5V | 5,056 | Volts | ok | 4,416 | 4,448 | 4,480 | 5,536 | 5,568 | 5,600 \n"
"+12V | 12,137 | Volts | ok | 10,600 | 10,653 | 10,706 | 13,250 | 13,303 | 13,356 \n"
"VBAT | 3,192 | Volts | ok | 2,880 | 2,904 | 2,928 | 3,648 | 3,672 | 3,696 \n"
"Fan1 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan2 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan3 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan4 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan5 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan6 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan7 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"Fan8 | na | RPM | na | 405,000 | 540,000 | 675,000 | 34155,000 | 34290,000 | 34425,000 \n"
"P1-DIMM1A Temp | 27,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P1-DIMM1B Temp | 26,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P1-DIMM2A Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P1-DIMM2B Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P1-DIMM3A Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P1-DIMM3B Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM1A Temp | 27,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM1B Temp | 26,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM2A Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM2B Temp | 28,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM3A Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"P2-DIMM3B Temp | 29,000 | degrees C | ok | -9,000 | -7,000 | -5,000 | 80,000 | 85,000 | 90,000 \n"
"Intrusion | 0x1 | discrete | 0x0100| na | na | na | na | na | na \n"
"PS Status | 0x1 | discrete | 0x0100| na | na | na | na | na | na ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")