re = /\b(?!red:|blue:|green:)[a-z]+(?=:)/
str = '(green:bar AND black:foo)
(blue:bar AND darkblue:foo)
(yellow:bar AND grey:foo)
(greengarden:bar AND red:foo)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end