const regex = /(?<=\(|AND )(?:(?:red:|blue:|green:)(*SKIP)(*FAIL)|[^:]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\(|AND )(?:(?:red:|blue:|green:)(*SKIP)(*FAIL)|[^:]+)', 'g')
const str = `(green:bar AND black:foo)
(blue:bar AND darkblue:foo)
(yellow:bar AND grey:foo)
(greengarden:bar AND red:foo)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}