use strict;
my $str = '------------------------------------------------------------------------------
REGEX to strip all whitelines ABOVE line with single closing curly bracket
------------------------------------------------------------------------------
```powershell
Describe {
Write-Host "As happening with InModuleScope.mdx"
It "Test Export-CSV" {
Get-ChildItem | Export-CSV -Path $filePath -NoTypeInformation
$dir = Import-CSV -Path $filePath
# ...
}
It "Test Export-Clixml" {
Get-ChildItem | Export-Clixml -Path $filePath
$dir = Import-Clixml -Path $filePath
# ...
}
';
my $regex = qr/(\n\n+\s+}|\n\n})/msp;
my $subst = '\\n}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";