# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\n\n+\s+}|\n\n})"
test_str = ("------------------------------------------------------------------------------\n"
"REGEX to strip all whitelines ABOVE line with single closing curly bracket\n"
"------------------------------------------------------------------------------\n\n"
"```powershell\n"
"Describe {\n"
" Write-Host \"As happening with InModuleScope.mdx\"\n\n"
" It \"Test Export-CSV\" {\n"
" Get-ChildItem | Export-CSV -Path $filePath -NoTypeInformation\n"
" $dir = Import-CSV -Path $filePath\n"
" # ...\n\n\n\n"
"}\n"
" It \"Test Export-Clixml\" {\n"
" Get-ChildItem | Export-Clixml -Path $filePath\n"
" $dir = Import-Clixml -Path $filePath\n"
" # ...\n\n"
" }\n\n")
subst = "\\n}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.