re = /(\n\n+\s+}|\n\n})/m
str = '------------------------------------------------------------------------------
REGEX to strip all whitelines ABOVE line with single closing curly bracket
------------------------------------------------------------------------------
```powershell
Describe {
Write-Host "As happening with InModuleScope.mdx"
It "Test Export-CSV" {
Get-ChildItem | Export-CSV -Path $filePath -NoTypeInformation
$dir = Import-CSV -Path $filePath
# ...
}
It "Test Export-Clixml" {
Get-ChildItem | Export-Clixml -Path $filePath
$dir = Import-Clixml -Path $filePath
# ...
}
'
subst = '\\n}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result