re = /payment no: (\d+)/m
str = 'Payment Instrument modified. payment no: 5000000000000000, method: C for transponder: 5000000000000000 transponder type: A
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end