using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"OPTIONS=\""(?:(.*)(-u [a-z]+:[a-z]+))?(.*?)\""";
string substitution = @"OPTIONS=""\1 \3 -u ntpd:ntpd""";
string input = @"OPTIONS=""-x -u wrong:wrong -c blah""
OPTIONS=""-u wrong:wrong -x -c blah""
OPTIONS=""-x -c blah -u wrong:wrong""
OPTIONS=""-x -c blah""";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}