import Foundation
let pattern = #"OPTIONS=\"(?:(.*)(-u [a-z]+:[a-z]+))?(.*?)\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
OPTIONS="-x -u wrong:wrong -c blah"
OPTIONS="-u wrong:wrong -x -c blah"
OPTIONS="-x -c blah -u wrong:wrong"
OPTIONS="-x -c blah"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"OPTIONS="\1 \3 -u ntpd:ntpd""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)