$re = '/(?:\b[\d]+[.,]?\b)+/m';
$str = '6,111,123,999 5,450,900 10.32 OCT21 Dec 31, 2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);