$re = '/^([^@\s]+@[^@\s]+\.[^@\s.]+;)+$/m';
$str = 'user1@xxx.com;
user1@xxx.com;user2@xxx.com;
user1@xxx.com;user2@xxx.com;user3@xxx.com;
user1@xxx.com
user1@xxx
user1@xxx.com;user2@xxx.com ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);