package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\/?[^a\/].*?>`)
var str = `<img src="www.test.com">. Next words <a href="www.abc.com">abc</a><a></a><div></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}