# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*<!\[CDATA\[de_DE\]\]>.*(?:\r?\n)?//gm;t' <<< "<supported-languages>
<lang><![CDATA[en_US]]></lang>
<lang><![CDATA[es_ES]]></lang>
<lang><![CDATA[de_DE]]></lang>
</supported-languages>
<2ndsupported-languages>
<lang><![CDATA[en_US]]></lang>
<lang><![CDATA[es_ES]]></lang>
<lang><![CDATA[de_DE]]></lang>
</2ndsupported-languages>"