#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*<!\[CDATA\[de_DE\]\]>.*(?:\r?\n)?"
Local $sString = "<supported-languages>" & @CRLF & _
" <lang><![CDATA[en_US]]></lang>" & @CRLF & _
" <lang><![CDATA[es_ES]]></lang>" & @CRLF & _
" <lang><![CDATA[de_DE]]></lang>" & @CRLF & _
"</supported-languages>" & @CRLF & _
"" & @CRLF & _
"<2ndsupported-languages>" & @CRLF & _
" <lang><![CDATA[en_US]]></lang>" & @CRLF & _
" <lang><![CDATA[es_ES]]></lang>" & @CRLF & _
" <lang><![CDATA[de_DE]]></lang>" & @CRLF & _
"</2ndsupported-languages>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)