# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".*<!\[CDATA\[de_DE\]\]>.*(?:\r?\n)?"
test_str = ("<supported-languages>\n"
" <lang><![CDATA[en_US]]></lang>\n"
" <lang><![CDATA[es_ES]]></lang>\n"
" <lang><![CDATA[de_DE]]></lang>\n"
"</supported-languages>\n\n"
"<2ndsupported-languages>\n"
" <lang><![CDATA[en_US]]></lang>\n"
" <lang><![CDATA[es_ES]]></lang>\n"
" <lang><![CDATA[de_DE]]></lang>\n"
"</2ndsupported-languages>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.