const regex = new RegExp('^(?:(?<Number>)(?<Prime>(?<SmallestFactor>(?<char>.)\\<char>+?))(?:\\<SmallestFactor>+(?<-Prime>(?=)))?(?!\\<char>)(?<-char>)(?(Prime)(?<-SmallestFactor>)(?<-Number>)|(?<Composite-Number>))|(?<Unit>.)|(?<MustUseTheSameCharacter>.+))$|(?<Zero>^$)', 'gm')
const str = `asdfaffafasdddafafasdfasddfasdfffdasssadfassdfsadfasd1111
1111111111111111111111111111111111111111111111111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}