$re = '/(<\/script>\s*\n)s$/m';
$str = '<script type="text/javascript"></script>
s';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;