using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?:\D*\d){10}(?:(?:\D*\d){3})?$)[\d-]+$";
string input = @"978-1-56619-909-4 2
978-1-56619-909-4
1-56619-909-3
1-56619-909-3
isbn446877428ydh
55 65465 4513574
1257561035
1248752418865";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}