$re = '/(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)/';
$str = '\'300\', \'3k\', \'3.2k\', \'0.0001k\', \'$15\', \'$30k\', 1000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);