re = /(?<value>\d+(?:\.\d+)?)(?<unit>[kmbt]?)/
str = '\'300\', \'3k\', \'3.2k\', \'0.0001k\', \'$15\', \'$30k\', 1000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end